System requirements

Scientific Learning designates officially supported requirements to help provide an optimal experience with mySciLEARN and the Fast ForWord product. However, the product may also operate on other, untested operating systems and browsers. If you have any questions about the requirements for your system setup, please contact Scientific Learning Customer Support at 1-888-358-0212 (US & Canada).

The requirements differ slightly based on current internet technology. Learn more about HTML5 and Adobe Flash.

Also on this page:

Fast ForWord HTML5
Reading Assistant Plus, Foundations I & II, Elements I, Reading Readiness & Levels 1-2, Reading Progress Indicator

Operating systems

 

• Windows 7/10

• Mac OS X 10.11 or later

• Chrome OS™

Not supported:

• Android

• Touchscreen

Browsers (latest versions)

 

• Chrome

• Firefox

• Microsoft Edge

• Safari (FFW only)

Not supported:

• Safari for RA+ on computer

• Internet Explorer

iPad

 

• iPad 5/iPad Air/Air 2 with iOS 11.3 or later

• Safari browser

Not supported:

• iOS 11.2 or earlier

Internet

 

Persistent internet connection that can support concurrent student usage

A typical student uses 50MB to 150MB of bandwidth per 30-minute session details

Other

 

• High-quality stereo headphones, with a Y adapter for teachers to listen in

• Approved microphone headset & USB adapter for Reading Assistant Plus see list

 

Legacy Fast ForWord Flash
Literacy (legacy) & Literacy Advanced, Reading Levels 3-5

Operating systems

 

• Windows 7/10

• Mac OS X 10.11 or later

• Chrome OS™

Not supported:

• Android

• Touchscreen

Browsers (latest versions)

 

• Chrome

• Firefox

• Microsoft Edge

• Safari

Not supported:

• Internet Explorer

iPad

 

• iPad 2/iPad Air/Air 2 with iOS 6 or later

• Up to 800 MB disk space for iPad apps

Not supported:

• iOS 5 or earlier

Internet

 

Persistent internet connection that can support concurrent student usage

A typical student uses 50MB to 150MB of bandwidth per 30-minute session details

Other

• Adobe Flash Player 10.3+

• High-quality stereo headphones, with a Y adapter for teachers to listen in

Internet recommendations for schools

Approved headphones & headsets lists

Troubleshooting browser display issues